Une fois que python a installé pyparsing, il ne demande aucun module nommé «pyparsing»

After Python Installs Pyparsing



J'ai installé matplotlib en utilisant pip sur l'interface de ligne de commande. Après avoir fait glisser les deux dossiers dans le dossier sitepackage du projet, je m'en fichais. J'ai signalé cette erreur lorsque je courais.

Raison: Il y a plus de deux fichiers nécessaires pour utiliser le package matplotlib:





À l'exception du dossier du package python, tous ont quelque chose à voir avec matplotlib, ou téléchargez ce dont vous avez besoin



Solution: Retirez tous les dossiers sauf pip dans le dossier de téléchargement par défaut de votre pip (vous ne pouvez pas le télécharger sans pip), puis utilisez pip pour télécharger à nouveau le package matplotlib, puis réimportez le package dans le sitepackage sous le fichier projet annuaire. franchir

problème résolu